In this session, we will provide an overview of how you can use IPv6 on AWS today – how to enable and migrate workloads at scale from IPv4-only to either dual-stack or IPv6-only architectures. We will cover the Amazon VPC IPv6 capabilities, how you can achieve IPv6 connectivity on AWS and hybrid network, and we’ll review common adoption patterns for hybrid connectivity, Internet-facing applications, and applications hosted on the edge. We’ll start with IPv6 address management on AWS using Amazon VPC IP Address Manager (IPAM) and take a step-by-step journey to an IPv6-enabled environment with Amazon VPC, peering, Transit Gateway and Cloud WAN, Direct Connect and VPN, are more.
Alexandra Huides Bio:
Alexandra Huides is working as a Networking Specialist Solutions Architect at AWS in Strategic Accounts. Alexandra is an experienced architect with extensive background in IPv4/IPv6 network design (routing/switching), network security (IPSEC/GRE/MPLS), troubleshooting, and network overlays/virtualization, software defined network design patterns and cloud networking solutions. She has designed and implemented multiple enterprise-scale networking solutions, spanning traditional data center technologies (Cisco/Juniper) and cloud vendors and services (AWS and Azure), and currently working with the largest scale AWS customers on their network infrastructure design.
IPv6 Extension Headers are an important part of the IPv6 protocol. In this session, we will learn:
- What are the frequently-used Extension Headers?
- What is the basic architecture?
- How are they used?
- What is the nature of the controversy surrounding them?
We will also present the results of our testing of IPv6 Extension Headers on the Internet and next steps.
The speaker will be Nalini Elkins, President of the Industry Network Technology Council.
Nalini’s Bio:
Nalini Elkins is the President of the Industry Network Technology Council. She is also the CEO and Founder of Inside Products, Inc. Nalini is a recognized leader in the field of computer performance measurement and analysis. In addition to being an experienced software product designer, developer, and planner, she has been the founder or co-founder of four start-ups in the high-tech arena.
Nalini started her career doing network design and monitoring for the Chevron network. She specializes in network performance analysis, measurement, monitoring, tuning, and troubleshooting of large enterprise networks.
One of her specialities is training and network design for IPv6 migration for large enterprises. Many of the Fortune 1000 level companies as well as the large US government organizations, have taken her classes on various networking topics.
She has developed network monitoring and diagnostic products, which were later marketed by IBM and other software companies. She received the A.A. Michelson award from the Computer Measurement Group for her contributions to the field. Nalini is on the Advisory Board of the India Internet Engineering Society (IIESoc).
Mesh routing is difficult, mesh routing for low power and lossy networks is straight up comatose. This session will help understand how the signalling/messaging works and depict sample packet captures for RPL signalling from real environments. It will also introduce tools apart from wireshark, such as scapy that can help construct/deconstruct the messaging. Obtaining performance data for mesh networks is another aspect covered in the session. What makes taking performance difficult? What are the best practices and some of the case studies? The session will also provide a demo into creating a sample 10 node RPL network on a laptop and getting the packet capture for the network formation.
Rahul Jadhav is an avid coder, and a system engineer working on solutions involving network and transport optimization. I have contributed towards more than a dozen open sources including Linux Kernel and worked closely with IETF Standards Working Groups (such as ROLL, 6lo, LWIG) and Linux Foundation Groups. Taken several projects from conception to market. Architected metering infrastructure based on 802.15.4G + PLC/6lo/RPL for Smart Grids and has a special interest in scalable mesh network architectures for low-power networks and has contributed towards IETF protocol standardization in the domain. Currently, I am part of the Accuknox team figuring out the best way to handle Zero-Trust based Security solutions involving Cloud/Edge/IoT.
IPv6 ND was designed for P2P and transit subnetworks with cheap and reliable broadcast capabilities. This session will explain how this is unfit with IoT wireless operation, and explain the operation of SFAAC (stateful address autoconfiguration) that was introduced with 6LoWPAN ND.
The talk will discuss how SFAAC interacts with RPL and proxy ND to build scalable multi-link subnetworks, where the L3 concepts of Link and Subnet are not necessarily congruent with the layer 2 broadcast domain.
Pascal’s Bio:
Pascal Thubert has been actively involved in research, development, and standards efforts on Internet mobility and wireless technologies since joining Cisco in 2000; he currently works at Cisco’s Chief Technology Office. Standards-wise, Pascal mostly contributes to the ETSI and the IETF. At the IETF, he co-chairs two IoT-related Working Groups and contributes to several others in the Internet and routing areas, where he authored 20+ RFCs the general context of IPv6, wireless, and the Internet of Things; he also contributed to the creation of DetNet and RAW and participates to the IEEE/IETF coordination, the INT Area and the IoT directorates. Pascal holds an Engineering Degree from the Ecole Centrale de Lyon and a Ph.D. from IMT Atlantique, and above 300 patents.
RPL, the IETF standard for routing in low power lossy networks, was designed to meet unusual constraints in terms of scale (high), device capabilities (limited), and link reliability and capacity (very low). To meet those constraints, RFC 6550 introduced a number of innovations with the use of anisotropic routing, stretched P2P path, autonomic properties, objective functions, multi-topology routing, and a distance-vector operation that is proactive in setup but reactive in maintenance. RPL is now being extended at one extreme with a fully ADHOC mode called AODV RPL, and a centrally controlled mode called Route Projection. This session will browse through the main features of RFC 6550 and the route projection work.
Pascal’s Bio:
The presenter, Pascal Thubert from Cisco, is a co-editor of RFC 8655 (the DetNet architecture), RFC 9030 (the 6TiSCH architecture), and the WIP draft RAW architecture, and well as the RPL routing protocol (RFC 6550), the 6LoWPAN Header Compression (RFC 6282) and Neighbor Discovery (RFC 8505 / 8928 / 8929) protocols.
